Added some buffalo docs.
[openwrt-10.03/.git] / docs / buildroot-documentation.html
index 9856c32a205888eb623be77d5abf4602b0a64fe0..48b05728e58ae628ec2ac23f2e0049350297de30 100644 (file)
@@ -428,7 +428,7 @@ foo-compile: bar-compile
 
 <pre>
      1  # $Id$
-     2  
+     2  include $(TOPDIR)/rules.mk
      3  PKG_NAME:=foo
      4  PKG_VERSION:=1.0
      5  PKG_RELEASE:=1
@@ -460,10 +460,10 @@ foo-compile: bar-compile
     31          );
     32          touch $(PKG_DIR)/.configured;
     33
-    34  $(PKG_DIR)/foo $(PKG_DIR)/.configured
+    34  $(PKG_DIR)/$(PKG_NAME): $(PKG_DIR)/.configured
     35          $(MAKE) CC=$(TARGET_CC) -C $(PKG_DIR)
     36
-    37  $(PKG_IPK): $(PKG_DIR)/$(PKG_BINARY)
+    37  $(PKG_IPK): $(PKG_DIR)/$(PKG_NAME)
     38         $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
     39          $(MAKE) prefix=$(PKG_IPK_DIR)/usr -C $(PKG_DIR) install
     40          rm -Rf $(PKG_IPK_DIR)/usr/man