[tools] firmware-utils/mkfwimage: fix root_start values
[openwrt-10.03/.git] / docs / Makefile
index cdaf09c1e04ffdb09afb9d38d6f477c1ab1e3377..a7fe08e50571828341d7a16084a5a7bdfe3f5d26 100644 (file)
@@ -1,6 +1,7 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
 
 all: compile
 
@@ -10,7 +11,7 @@ include $(INCLUDE_DIR)/prereq.mk
 MAIN = openwrt.tex
 DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-compile:
+compile: $(TMP_DIR)/.prereq-docs
        $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
        $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
@@ -37,7 +38,7 @@ $(eval $(call RequireCommand,latex, \
        You need to install LaTeX to build the OpenWrt documentation \
 ))
 $(eval $(call RequireCommand,pdflatex, \
-       You need to install LaTeX to build the OpenWrt documentation \
+       You need to install PDFLaTeX to build the OpenWrt documentation \
 ))
 $(eval $(call RequireCommand,htlatex, \
        You need to install tex4ht to build the OpenWrt documentation \