makes ledtrignetdev work on .26 and fix whitespaces
[openwrt-10.03/.git] / docs / Makefile
index f6caa826030da721a568ac5efef0eed87b18cabe..8bae4625af991c77ad6b1ab6303a6383b493526f 100644 (file)
@@ -1,6 +1,7 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
 
 all: compile
 
@@ -10,13 +11,14 @@ include $(INCLUDE_DIR)/prereq.mk
 MAIN = openwrt.tex
 DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-compile:
+compile: $(TMP_DIR)/.prereq-docs
        $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
        $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
        $(NO_TRACE_MAKE) cleanup
 
 $(TMP_DIR)/.prereq-docs:
+       mkdir -p $(TMP_DIR)
        $(NO_TRACE_MAKE) prereq
        touch $@
 
@@ -25,7 +27,7 @@ openwrt.html: $(DEPS)
 
 openwrt.pdf: $(DEPS)
        pdflatex $(MAIN)
-       
+
 clean: cleanup
        rm -f openwrt.pdf openwrt.html openwrt.css