network scripts: revert the network state after running ifdown, not before
[openwrt-10.03/.git] / docs / Makefile
index 9e888a4af2df7fab545631ffe872b16106738ffb..8bae4625af991c77ad6b1ab6303a6383b493526f 100644 (file)
@@ -1,21 +1,25 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
+
+all: compile
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-all:
-       $(MAKE) cleanup
+compile: $(TMP_DIR)/.prereq-docs
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
 
-.prereq:
-       $(MAKE) prereq
+$(TMP_DIR)/.prereq-docs:
+       mkdir -p $(TMP_DIR)
+       $(NO_TRACE_MAKE) prereq
        touch $@
 
 openwrt.html: $(DEPS)
@@ -23,13 +27,16 @@ openwrt.html: $(DEPS)
 
 openwrt.pdf: $(DEPS)
        pdflatex $(MAIN)
-       
+
 clean: cleanup
        rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,latex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
 $(eval $(call RequireCommand,pdflatex, \
        You need to install LaTeX to build the OpenWrt documentation \
 ))