typo
[openwrt-10.03/.git] / Makefile
index 172e1b80c2d834481f9c620424431969de60f924..e490078bc5971123ac6b7a37fad3ad6e1eb175e1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,8 +48,7 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 # along with the packages to build for the target.
 #
 ##############################################################
-TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
-TARGETS+=linux
+TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils linux openwrt
 
 include toolchain/Makefile.in
 include package/Makefile.in
@@ -118,6 +117,8 @@ $(TARGET_DIR):
        fi;
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
+       -ln -sf /tmp/resolv.conf $(TARGET_DIR)/etc
+       -mkdir -p $(TARGET_DIR)/jffs
 
 source: $(TARGETS_SOURCE)
 
@@ -166,27 +167,48 @@ $(CONFIG)/mconf:
        fi
 
 menuconfig: $(CONFIG)/mconf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 config: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 oldconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 randconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 allyesconfig: $(CONFIG)/conf
        #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
        #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 allnoconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 defconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 #############################################################
 #
@@ -203,3 +225,5 @@ endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend
 
+targets:
+       @echo $(TARGETS)