try to add with correct permissions later
[openwrt-10.03/.git] / Makefile
index 3d9bcb3870677a2ecc98cf3fc91e4ec64a631637..cd9423314937b2e7ca45a585419b085397c95dc0 100644 (file)
--- a/Makefile
+++ b/Makefile
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+ifneq ($(DEVELOPER),)
+CONFIG_CONFIG_IN = Config.in.devel
+else
 CONFIG_CONFIG_IN = Config.in
+endif
 CONFIG_DEFCONFIG = .defconfig
 CONFIG = package/config
 
@@ -41,6 +45,8 @@ include $(TOPDIR)/rules.mk
 
 all: world
 
+.NOTPARALLEL:
+
 ##############################################################
 #
 # Build the toolchain
@@ -55,8 +61,11 @@ toolchain_install:
 #
 ##############################################################
 
-package_install: toolchain
-       $(MAKE) -C package compile install
+package_compile: target_compile
+       $(MAKE) -C package compile
+
+package_install: package_compile toolchain
+       $(MAKE) -C package install
 
 #############################################################
 #
@@ -85,6 +94,9 @@ package_index:
 target_prepare:
        $(MAKE) -C target prepare
 
+target_compile:
+       $(MAKE) -C target compile
+
 target_install:
        $(MAKE) -C target install