sync with buildroot2 from uclibc, add two variables PACKAGE_DIR and PATCH, remove...
[openwrt-10.03/.git] / Makefile
index c2e628051aec229c9ac5d82e72f2d06b1d7573dc..b240492b897fa2bb2cd76871633c5a28ca031443 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -107,6 +107,8 @@ $(STAGING_DIR):
 $(TARGET_DIR):
        @mkdir -p $(TARGET_DIR)
        cp -a target/default/target_skeleton/* $(TARGET_DIR)/
+       mkdir -p $(TARGET_DIR)/{proc,dev,jffs,tmp,usr/sbin}
+       chmod 1777 $(TARGET_DIR)/tmp
        -find $(TARGET_DIR) -type d -name CVS -exec rm -rf {} \; > /dev/null 2>&1
 
 source: $(TARGETS_SOURCE)
@@ -118,6 +120,7 @@ source: $(TARGETS_SOURCE)
 #############################################################
 clean:
        rm -rf $(BUILD_DIR) $(IMAGE).*
+       -rm -f openwrt-*
        @$(MAKE) -C $(CONFIG) clean
 
 distclean: clean
@@ -178,7 +181,7 @@ defconfig: $(CONFIG)/conf
 # Cleanup and misc junk
 #
 #############################################################
-clean:
+clean: 
        @$(MAKE) -C $(CONFIG) clean
 
 distclean: clean