add missing copyright
[openwrt-10.03/.git] / Makefile
index faeecaa4881e5c7dd2058f5d7ef2b82ba24b2349..5c218f155f761ad163748febcd733d805af4fbc4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -26,6 +16,7 @@ RELEASE:=Kamikaze
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -45,7 +36,7 @@ ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
@@ -87,7 +78,7 @@ toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
 .config: ./scripts/config/conf FORCE
-       @[ -f .config ] || $(MAKE) menuconfig
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
        $< -D .config Config.in >/dev/null 2>/dev/null
 
 download: .config FORCE