Always use -R flag with cp (to preserve symlinks)
[openwrt-10.03/.git] / Makefile
index fd2a4ad8e49e228c6501cadba0fe23d65973a4b3..1b8d968a0995a291cdb0fd549542daf81c5c5ff7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,6 +45,8 @@ include $(TOPDIR)/rules.mk
 
 all: world
 
+.NOTPARALLEL:
+
 ##############################################################
 #
 # Build the toolchain
@@ -59,8 +61,11 @@ toolchain_install:
 #
 ##############################################################
 
-package_install: toolchain
-       $(MAKE) -C package compile install
+package_compile: target_compile
+       $(MAKE) -C package compile
+
+package_install: package_compile toolchain
+       $(MAKE) -C package install
 
 #############################################################
 #
@@ -69,7 +74,6 @@ package_install: toolchain
 #
 #############################################################
 
-
 # In this section, we need .config
 include .config.cmd
 
@@ -89,6 +93,9 @@ package_index:
 target_prepare:
        $(MAKE) -C target prepare
 
+target_compile:
+       $(MAKE) -C target compile
+
 target_install:
        $(MAKE) -C target install
 
@@ -100,6 +107,16 @@ $(BUILD_DIR):
 
 source: $(TARGETS_SOURCE)
 
+
+package/%:
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
 #############################################################
 #
 # Cleanup and misc junk
@@ -112,6 +129,7 @@ image_clean:
        
 target_clean: image_clean
        rm -rf $(TARGET_DIR)
+       rm -rf $(BUILD_DIR)/linux-*/root
 
 clean: target_clean
        @$(MAKE) -C $(CONFIG) clean